FINAL FANTASY XI
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2021/07/16 19:20 from FINAL FANTASY XI

Square Enix European Support Centre - Increased Contact Volume

Due to a record number of contacts, it may take us longer to respond to your query than usual and we apologise for any delays in response you're experiencing.

Remember to make use of our Knowledge Base articles at https://support.eu.square-enix.com/ before submitting a ticket as this helps us to prioritise the most urgent cases.

Please also pay particular attention to the following articles:

Important Information about Account Access Recovery
https://support.eu.square-enix.com/news.php?id=612&la=2&n=2&drt=1588852800&tag=221d6978e32851c180dca974f8eb5f2c41eb74da

Important Notice to All Software Token Users
https://support.eu.square-enix.com/faqarticle.php?id=5383&la=2&kid=78777&ret=faq

Our Support Centre team continues to work from home and to help us reply to all queries as quickly as possible, we are only providing assistance via email and the in-game Game Master service at the moment.

We are grateful for your patience and understanding during this time and assure you that we are doing our very best to address all of your enquiries as soon as we can.

[Date & Time]
From July 12, 2021

[Details]
Support Centre Services

[Cause]
Record number of contacts

[Affected Services]
Square Enix EU Support Centre

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