Square Enix Account
View pages of related service:
Latest News
Important Notices
2020/03/24 09:30 from Square Enix Account

Square Enix European Support Closed – COVID-19 Update (Mar. 24)

As a result of the increased measures to combat the spread of COVID-19 announced in the UK, we are sorry to announce that we have to temporarily close the European Square Enix Support Centre.

We are doing our best to re-open services as soon as possible, while maintaining the wellbeing and safety of our teams.
You can still send us enquiries via the Support Centre website but responses will take longer than usual. We encourage you to make use of the in-game Knowledge Base articles in the Support Desk menu or from the Support Centre website at https://support.eu.square-enix.com/ before submitting a ticket.

In-game GM support remains available but please only make an in-game call if you urgently need assistance.

We apologise for any inconvenience caused and thank you for your patience and understanding during these unprecedented circumstances.

[Date & Time]
From Mar. 24, 2020 at 9:00 GMT

[Details]
Support unavailable

[Cause]
Support Centre closed

[Affected Services]
Square Enix EU Support Centre
- Email, chat and phone support

We use cookies on our websites. You are free to manage this via your browser setting at any time. To learn more about how we use the cookies, please see our cookies policy.

You probably won’t be surprised to hear that we’ve updated our Privacy Notice. Please do take the time to read our new, more informative, easier to read and easier to understand, Privacy Notice.