FINAL FANTASY XI
View pages of related service:
Latest News
Important Notices
2020/03/23 22:00 from FINAL FANTASY XI

Square Enix European Support Centre – COVID-19 Update (Mar. 23)

Due to the extraordinary circumstances and fast evolving global situation the world is facing with the COVID-19 pandemic, we want to update you on how this may impact you when contacting SQUARE ENIX Customer Support.

While the Square Enix European Support Centre remains open, we are taking every precaution to ensure our teams work in as safe an environment as possible. We’re doing our best to keep disruption to support to a minimum, while ensuring tickets are resolved in a timely manner.

As a result of the measures we are taking, you may experience longer waiting times than usual. We encourage you to make use of the in-game Knowledge Base articles in the Support Desk menu or from the Support Centre website at https://support.eu.square-enix.com/ before submitting a ticket.

We apologise for any inconvenience this may cause you and appreciate your patience and understanding throughout this challenging period.

[Date & Time]
From Mar. 23, 2020

[Details]
Longer response times

[Cause]
Reduced support staffing

[Affected Services]
Square Enix EU Support Centre
- Email, chat and phone support
- FFXIV and FFXI EU in-game support

We use cookies on our websites. You are free to manage this via your browser setting at any time. To learn more about how we use the cookies, please see our cookies policy.

You probably won’t be surprised to hear that we’ve updated our Privacy Notice. Please do take the time to read our new, more informative, easier to read and easier to understand, Privacy Notice.