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2020/08/20 15:00 from FINAL FANTASY XI

Square Enix European Support Centre Limited Services – COVID-19 Update (Aug 20)

As the global COVID-19 situation continues, Square Enix European Support Centre services remain limited while our teams work from home.

We are currently providing support by email only. Unfortunately we are unable to offer phone and chat support at present.

We are receiving a large volume of contacts at the moment, which may mean you wait longer than usual for our response, but please rest assured that we are working as hard as ever to get back to you as soon as possible.

We are grateful for your understanding and patience and assure you that we will be restoring all avenues of support as soon as we can.

[Date & Time]
From Mar. 24, 2020

[Details]
Live support services unavailable

[Cause]
Reduced support capacity

[Affected Services]
Square Enix EU Support Centre
- Chat and Phone support

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