PlayOnline
View pages of related service:
Latest News
Status
2023/11/06 13:00 from PlayOnline

Recovery from Square Enix Account Management System Issues (Nov. 6)

We are pleased to announce that the Square Enix Account Management System issues listed below have been resolved.

We apologise for any inconvenience caused, and thank you for your understanding.

[Date & Time]
Nov. 6, 2023 5:00 to 05:58 (GMT)

[Details]
Customers who are using the Software Authenticator were unable to login into the services below.
• PlayOnline
• FINAL FANTASY XI Forum

*Customer who are using the “Square Enix Security Token (Key Ring Type)” and “Square Enix Software Token” were not affected by this issue.

[Cause]
Server Issue

[Affected Services]
PlayOnline
FINAL FANTASY XI Forum

We use cookies on our websites. You are free to manage this via your browser setting at any time. To learn more about how we use the cookies, please see our cookies policy.

You probably won’t be surprised to hear that we’ve updated our Privacy Notice. Please do take the time to read our new, more informative, easier to read and easier to understand, Privacy Notice.