PlayOnline
View pages of related service:
Latest News
Status
2020/04/27 23:50 from PlayOnline

Customer Support Technical Issues Recovery (Apr. 27)

We are pleased to announce that the Support Centre and in-game Helpdesk technical difficulties are now resolved.

Users are now able to send enquiries and reports.

Should you still get an error message when sending a message please make sure to try again.

We apologise for any inconvenience this may have caused we thank you for your understanding.

[Date & Time]
From Apr. 27, 2020 15:43 to 18:52 (BST)

[Details]
Unable to send enquiries and reports to the Support Centre and in-game Helpdesk

[Cause]
Heavy stress loads on the server equipment

[Affected]
Customers requiring support

* Updated: Aug. 18, 2020 08:20 (BST)
Cause updated.

We use cookies on our websites. You are free to manage this via your browser setting at any time. To learn more about how we use the cookies, please see our cookies policy.

You probably won’t be surprised to hear that we’ve updated our Privacy Notice. Please do take the time to read our new, more informative, easier to read and easier to understand, Privacy Notice.