Square Enix Account
View pages of related service:
Latest News
Important Notices
2020/03/26 02:00 from Square Enix Account

Square Enix European Support Closed – COVID-19 Update (Mar. 25): Follow-up

The teams at Square Enix have been hard at work to get our support staff back online and we are happy to inform you that the European Support Centre has now resumed email support.

If you have already submitted a query to us, please rest assured we are doing our best to get back to you as soon as we can.

We continue to encourage you to make use of our Knowledge Base articles at https://support.eu.square-enix.com/ before submitting your questions.

Please note that phone and live chat options will be unavailable until further notice.
We are working to restore full service as soon as possible and will provide updates as soon as we can.

Thank you for your patience and bearing with us throughout this challenging time.

[Date & Time]
From Mar. 25, 2020 at 9:00 GMT

[Details]
Email support available
Live support services unavailable

[Cause]
Reduced capacities

[Affected Services]
Square Enix EU Support Centre
- Phone and chat support

We use cookies on our websites. You are free to manage this via your browser setting at any time. To learn more about how we use the cookies, please see our cookies policy.

You probably won’t be surprised to hear that we’ve updated our Privacy Notice. Please do take the time to read our new, more informative, easier to read and easier to understand, Privacy Notice.