FINAL FANTASY XI
View pages of related service:
Latest News
General
2018/03/01 15:35 from FINAL FANTASY XI

EU Information Centre Limited Service (Feb. 28): Follow up 2

We are pleased to inform you we will resume limited email assistance from tomorrow, Friday 2 March at 9:00 (GMT). Chat and phone services will remain unavailable until further notice due to the continuing severe weather, which is necessitating that the EU Support Centre team runs with minimal staff.

We apologise for the inconvenience this may cause.

We’re hoping to resume full support services by Monday 5 March, 9:00 (GMT) and will update as additional information becomes available.

Thank you once again for your patience and understanding during these exceptional weather conditions.

[Date & Time]
Since Feb. 28, 2018 at 13:15 (GMT)

[Details]
Chat and phone support unavailable
Support Centre services limited to email assistance

[Cause]
Severe weather conditions

[Affected Services]
Chat and phone support

We use cookies on our websites. You are free to manage this via your browser setting at any time. To learn more about how we use the cookies, please see our cookies policy.

You probably won’t be surprised to hear that we’ve updated our Privacy Notice. Please do take the time to read our new, more informative, easier to read and easier to understand, Privacy Notice.