FINAL FANTASY XI
View pages of related service:
Latest News
General
2018/03/01 09:35 from FINAL FANTASY XI

EU Information Centre Services Unavailable (Feb. 28): Follow-up

As a result of the worsening weather conditions in the UK, we're very sorry to inform you that EU Support Centre services will remain unavailable on Thursday, March 1st.

Please rest assured that we are doing all we can to resume services as quickly as possible, while also ensuring the safety of all Square Enix Support team members.

Please accept our sincere apologies for the continued inconvenience that this may cause. We'll continue to monitor the situation and provide you with updates as they become available.

Thanks once again for your understanding and support, while we endeavour to restore services to you.

[Date & Time]
Since Feb. 28, 2018 at 13:15 (GMT)

[Details]
Support Centre unavailable

[Cause]
Severe weather conditions

[Affected Services]
Chat, email and phone support

We use cookies on our websites. You are free to manage this via your browser setting at any time. To learn more about how we use the cookies, please see our cookies policy.

You probably won’t be surprised to hear that we’ve updated our Privacy Notice. Please do take the time to read our new, more informative, easier to read and easier to understand, Privacy Notice.